summaryrefslogtreecommitdiffstats
path: root/misc/buildroot
diff options
context:
space:
mode:
authorpatacongo <patacongo@7fd9a85b-ad96-42d3-883c-3090e2eb8679>2010-09-02 23:15:24 +0000
committerpatacongo <patacongo@7fd9a85b-ad96-42d3-883c-3090e2eb8679>2010-09-02 23:15:24 +0000
commitf914115a7c933b115544021dd1497efc83f5196b (patch)
treeb7340c49b90a405c269daf4e2eb3d548e522b47c /misc/buildroot
parent5032971faad6a0781952ac1ca7b556f1f4f38ffa (diff)
Add --disable-werror to gdb.mk
git-svn-id: https://nuttx.svn.sourceforge.net/svnroot/nuttx/trunk@2912 7fd9a85b-ad96-42d3-883c-3090e2eb8679
Diffstat (limited to 'misc/buildroot')
-rw-r--r--misc/buildroot/ChangeLog4
-rw-r--r--misc/buildroot/toolchain/gdb/gdb.mk1
2 files changed, 5 insertions, 0 deletions
diff --git a/misc/buildroot/ChangeLog b/misc/buildroot/ChangeLog
index 656c46dfdd..b2d991c5c4 100644
--- a/misc/buildroot/ChangeLog
+++ b/misc/buildroot/ChangeLog
@@ -70,4 +70,8 @@ buildroot-1.9 2010-xx-xx <spudmonkey@racsa.co.cr>
* configs/arm926t-defconfig-nxflat: NXFLAT-only configuration for
arm926
* toolchain/gdb/gdb.mk - Remove ncurses dependency from gdb_target target.
+ * toolchain/gdb/gdb.mk - Added --disable-werror to GDB configuration line.
+ GDB 6.8 won't build because the tarbal was released with -Werror enabled and
+ the build stops on the first warning.
+
diff --git a/misc/buildroot/toolchain/gdb/gdb.mk b/misc/buildroot/toolchain/gdb/gdb.mk
index 5417685d92..aa9e126bc0 100644
--- a/misc/buildroot/toolchain/gdb/gdb.mk
+++ b/misc/buildroot/toolchain/gdb/gdb.mk
@@ -79,6 +79,7 @@ $(GDB_TARGET_DIR)/.configured: $(GDB_DIR)/.unpacked
--disable-tui --disable-gdbtk --without-x \
--disable-sim --enable-gdbserver \
--without-included-gettext \
+ --disable-werror \
);
ifeq ($(BR2_ENABLE_LOCALE),y)
-$(SED) "s,^INTL *=.*,INTL = -lintl,g;" $(GDB_DIR)/gdb/Makefile