aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-osmocom/libosmo-abis/libosmo-abis_git.bb4
-rw-r--r--recipes-osmocom/libosmo-netif/libosmo-netif_git.bb4
-rw-r--r--recipes-osmocom/libosmo-sccp/libosmo-sccp_git.bb11
-rw-r--r--recipes-osmocom/libosmocore/libosmocore_git.bb4
-rw-r--r--recipes-osmocom/openbsc/openbsc/revert-mncc-version.patch19
-rw-r--r--recipes-osmocom/openbsc/openbsc_git.bb7
-rw-r--r--recipes-osmocom/openggsn/openggsn_git.bb6
7 files changed, 26 insertions, 29 deletions
diff --git a/recipes-osmocom/libosmo-abis/libosmo-abis_git.bb b/recipes-osmocom/libosmo-abis/libosmo-abis_git.bb
index 8010389..c9c2077 100644
--- a/recipes-osmocom/libosmo-abis/libosmo-abis_git.bb
+++ b/recipes-osmocom/libosmo-abis/libosmo-abis_git.bb
@@ -1,7 +1,9 @@
require ${PN}.inc
+DEPENDS += "libtalloc"
+
S = "${WORKDIR}/git"
-SRCREV = "3cef39b03cb46de4a7aba65137d724a000b184cb"
+SRCREV = "35003ec2ea7de49d67e5332938a66fe92580b94d"
SRC_URI = "git://git.osmocom.org/libosmo-abis.git;protocol=git"
PV = "0.3.2+gitr${SRCPV}"
PR = "${INC_PR}.1"
diff --git a/recipes-osmocom/libosmo-netif/libosmo-netif_git.bb b/recipes-osmocom/libosmo-netif/libosmo-netif_git.bb
index bbfa7c0..bea2435 100644
--- a/recipes-osmocom/libosmo-netif/libosmo-netif_git.bb
+++ b/recipes-osmocom/libosmo-netif/libosmo-netif_git.bb
@@ -1,7 +1,9 @@
require ${PN}.inc
+DEPENDS += "libtalloc lksctp-tools"
+
S = "${WORKDIR}/git"
-SRCREV = "efb9af4dada5e2426e69d670f4549f8fec3c9cb2"
+SRCREV = "243a3b0372fe738b01c2d32d6f6cb7b7c99a1180"
SRC_URI = "git://git.osmocom.org/libosmo-netif.git;protocol=git"
PV = "0.4.0+gitr${SRCPV}"
PR = "${INC_PR}.2"
diff --git a/recipes-osmocom/libosmo-sccp/libosmo-sccp_git.bb b/recipes-osmocom/libosmo-sccp/libosmo-sccp_git.bb
new file mode 100644
index 0000000..60c5b54
--- /dev/null
+++ b/recipes-osmocom/libosmo-sccp/libosmo-sccp_git.bb
@@ -0,0 +1,11 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "882f340b6c394f581f6c32cafefa10c7b57073b9"
+SRC_URI = "git://git.osmocom.org/libosmo-sccp.git;protocol=git"
+PR = "${INC_PR}.1"
+
+# because "${WORKDIR}/git" is not a git repo, it can't figure out the version
+do_configure_prepend() {
+ echo "${PV}" > ${S}/.tarball-version
+}
diff --git a/recipes-osmocom/libosmocore/libosmocore_git.bb b/recipes-osmocom/libosmocore/libosmocore_git.bb
index e482f8c..964dea2 100644
--- a/recipes-osmocom/libosmocore/libosmocore_git.bb
+++ b/recipes-osmocom/libosmocore/libosmocore_git.bb
@@ -1,11 +1,13 @@
require ${PN}.inc
S = "${WORKDIR}/git"
-SRCREV = "70fcbda6dd733a503e9a046e01986d8bfc2e2bb2"
+SRCREV = "a8a8d3977dc3b31352f8a87ca005763677bd7e8c"
SRC_URI = "git://git.osmocom.org/libosmocore.git;protocol=git;nobranch=1"
PV = "0.9.0+gitr${SRCPV}"
PR = "r1"
+DEPENDS += "libtalloc"
+
PACKAGES =+ "libosmoctrl libosmocodec libosmogb libosmogsm libosmovty osmo-arfcn osmo-auc-gen"
FILES_libosmoctrl = "${libdir}/libosmoctrl${SOLIBS}"
FILES_libosmocodec = "${libdir}/libosmocodec${SOLIBS}"
diff --git a/recipes-osmocom/openbsc/openbsc/revert-mncc-version.patch b/recipes-osmocom/openbsc/openbsc/revert-mncc-version.patch
deleted file mode 100644
index c4c2ee8..0000000
--- a/recipes-osmocom/openbsc/openbsc/revert-mncc-version.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-OpenBSC has bumped the version from 2 to 4 but only introduced
-new defines so the actual wire protocol has not been changed
-yet. This is why we can just turn the version back. At least I
-hope so.
-
-
-Index: openbsc/include/openbsc/mncc.h
-===================================================================
---- openbsc.orig/include/openbsc/mncc.h
-+++ openbsc/include/openbsc/mncc.h
-@@ -163,7 +163,7 @@ struct gsm_data_frame {
- unsigned char data[0];
- };
-
--#define MNCC_SOCK_VERSION 4
-+#define MNCC_SOCK_VERSION 2
- struct gsm_mncc_hello {
- uint32_t msg_type;
- uint32_t version;
diff --git a/recipes-osmocom/openbsc/openbsc_git.bb b/recipes-osmocom/openbsc/openbsc_git.bb
index 920ba34..ac0d257 100644
--- a/recipes-osmocom/openbsc/openbsc_git.bb
+++ b/recipes-osmocom/openbsc/openbsc_git.bb
@@ -1,11 +1,10 @@
require ${PN}.inc
-PV = "0.14.0+gitr${SRCPV}"
+PV = "0.15.0+gitr${SRCPV}"
PRINC = "0"
PR = "${INC_PR}.6"
-SRCREV = "57ee78078905c7499bd4e6857f8981d22badfcac"
-SRC_URI += "git://git.osmocom.org/openbsc.git;protocol=git \
- file://upgrade-mncc-version.patch"
+SRCREV = "ba66e79953cb1c2230fe2916ef7d8de78500c7fd"
+SRC_URI += "git://git.osmocom.org/openbsc.git;protocol=git"
S = "${WORKDIR}/git/openbsc"
diff --git a/recipes-osmocom/openggsn/openggsn_git.bb b/recipes-osmocom/openggsn/openggsn_git.bb
index 790bf56..d704bc5 100644
--- a/recipes-osmocom/openggsn/openggsn_git.bb
+++ b/recipes-osmocom/openggsn/openggsn_git.bb
@@ -1,10 +1,10 @@
DESCRITOPN = "OpenGGSN a Free Software GGSN"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
-PV = "0.91+gitr${SRCPV}"
-PR = "r14"
+PV = "0.92+gitr${SRCPV}"
+PR = "r1"
-SRCREV = "b07d07072e70ac4f920be9dfdf45615193b4ec2d"
+SRCREV = "283188790bb1b3af673d4edbd56ff649b7464e1e"
SRC_URI = "git://git.osmocom.org/openggsn \
file://openggsn.init \
file://libgtp-queue_depth_32.patch \