aboutsummaryrefslogtreecommitdiffstats
path: root/cli/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cli/test/Makefile.am')
-rw-r--r--cli/test/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/cli/test/Makefile.am b/cli/test/Makefile.am
new file mode 100644
index 0000000..b3be3c0
--- /dev/null
+++ b/cli/test/Makefile.am
@@ -0,0 +1,23 @@
+
+noinst_PROGRAMS = \
+ test-helpers
+
+test_helpers_SOURCES = \
+ test-helpers.c \
+ $(top_srcdir)/cli/qmicli-helpers.h \
+ $(top_srcdir)/cli/qmicli-helpers.c
+
+test_helpers_CPPFLAGS = \
+ $(QMICLI_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/cli
+
+test_helpers_LDADD = \
+ $(QMICLI_LIBS)
+
+if WITH_TESTS
+
+check-local: test-helpers
+ $(abs_builddir)/test-helpers
+
+endif