aboutsummaryrefslogtreecommitdiffstats
path: root/src/ctrl/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-05-26 17:07:39 +0200
committerHarald Welte <laforge@gnumonks.org>2018-05-26 21:58:11 +0200
commited6057841dd094f95efebbeae51a85bd0879463f (patch)
tree42746681b44acc6f13e53f2e6849a911dd01a6f0 /src/ctrl/Makefile.am
parent3b8921fae2754c02a47f29238490d4ed2836353d (diff)
ctrl: Introduce libosmoctrl.map to avoid unintended exports
There are some symbols for use between control_cmd.c and control_if.c, which are not supposed to be exported publicly. Let's make sure we keep those symbols local. Change-Id: Ia85f36a9c4b2ebf4003718e0a230959638370320
Diffstat (limited to 'src/ctrl/Makefile.am')
-rw-r--r--src/ctrl/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ctrl/Makefile.am b/src/ctrl/Makefile.am
index 71cc9a37..a51ae053 100644
--- a/src/ctrl/Makefile.am
+++ b/src/ctrl/Makefile.am
@@ -20,4 +20,6 @@ if ENABLE_VTY
libosmoctrl_la_SOURCES += control_vty.c
endif
+EXTRA_DIST = libosmoctrl.map
+
endif