aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2017-01-13 16:03:40 +0700
committerHarald Welte <laforge@gnumonks.org>2017-03-06 17:06:45 +0000
commit77a5b0946f67d0228a4dbb5a04940070e12ebf2f (patch)
treef812207447f0bec75af84bb1a8e0585a7cc0ab71 /include/Makefile.am
parent804c4c7d423f85f610fdbafe846edf04c7140c4b (diff)
gsm0503.h: generate header automatically
Since we have automatic header generation, implemented in the utils/conv_gen.py, it's time to use this feature! Change-Id: I21caa4e433b2cc1861611e35350a9671da444c2a
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 0a300a84..770a9c62 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -143,3 +143,9 @@ osmocom/core/bit%gen.h: osmocom/core/bitXXgen.h.tpl
osmocom/core/crc%gen.h: osmocom/core/crcXXgen.h.tpl
$(AM_V_GEN)$(MKDIR_P) $(dir $@)
$(AM_V_GEN)sed -e's/XX/$*/g' $< > $@
+
+osmocom/gsm/gsm0503.h:
+ $(AM_V_GEN)python2 $(top_srcdir)/utils/conv_gen.py gen_header gsm \
+ --target-path $(top_srcdir)/include/osmocom/gsm/
+
+CLEANFILES = osmocom/gsm/gsm0503.h