aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2016-01-18 13:30:28 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2016-01-18 13:52:59 +0100
commite7c18dd59f4f91409e8d8854eee2d213165e0746 (patch)
tree7cd6eb08ec4a73c66a81b234146024397946068a /debian
parentf6d9f3759cf764d74c22dc190851371379b221de (diff)
debian: Avoid linking with -Bsymbolic-functions
Our tests want to be able to change symbols from the library and even by using --wrap=XYZ it is not possible right now. One option would be to use static linking but that is not always enabled, the other is to skip tests on Ubuntu and the third one is to disable that linking mode. This means that the dynamic linker needs to spend some more time but we do spend this time on all other distros and this looks acceptable.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c1cb97b1..a6a2cfc9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,9 @@ DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+# Our tests want to override symbols, make it possible on Ubuntu
+export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS | sed -e 's/-Wl,-Bsymbolic-functions//')
+
export DEB_BUILD_HARDENING=1
%: