aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2018-01-18 16:05:27 +0100
committerHarald Welte <laforge@gnumonks.org>2018-01-21 19:05:00 +0000
commit89c8c4027b54cb1d20448a7c624b373b40823403 (patch)
tree96e7fc75a7380a6a0bda708a60f034c517ec1a3d /configure.ac
parent0bbf67dfd3d97c67a126e60de2c5648c88427981 (diff)
Embedded: disable stats test
As of 67bdd80a96bdfc49d1aadbd32cca2b53f123d180 the stats.c is effectively disable so we should disable the corresponding tests as well. Change-Id: I42ff7a6619c0a5926fdc2ec779cf04689c567e15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f7acf05c..3c158962 100644
--- a/configure.ac
+++ b/configure.ac
@@ -236,6 +236,9 @@ AC_ARG_ENABLE(embedded,
[Enable building for embedded use and disable unsupported features]
)],
[embedded=$enableval], [embedded="no"])
+
+AM_CONDITIONAL(ENABLE_STATS_TEST, true)
+
if test x"$embedded" = x"yes"
then
AC_DEFINE([EMBEDDED],[1],[Select building for embedded use])
@@ -250,6 +253,7 @@ then
AM_CONDITIONAL(ENABLE_GNUTLS, false)
AM_CONDITIONAL(ENABLE_PCSC, false)
AM_CONDITIONAL(ENABLE_PSEUDOTALLOC, true)
+ AM_CONDITIONAL(ENABLE_STATS_TEST, false)
AC_DEFINE([USE_GNUTLS], [0])
AC_DEFINE([PANIC_INFLOOP],[1],[Use infinite loop on panic rather than fprintf/abort])
fi