aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVasil Velichkov <vvvelichkov@gmail.com>2019-04-03 02:32:37 +0300
committerneels <nhofmeyr@sysmocom.de>2019-11-30 02:17:23 +0000
commit499510bd521279e406ea3c0126923264341faa03 (patch)
tree58fb498f1144133a5330edcd99b9aa762fdf3683 /configure.ac
parent153642348febb08d37ba127ad21c9e3835a67791 (diff)
Add code coverage support
The coverage report shows what code is covered by tests and what is not and the ratio could be tracked over time. These reports will allow us to identify code that is not being tested and improve the test suites. To enable the reports configure with --enable-code-coverage and execute "make check-code-coverage". The HTML report will be generated in a subdirectory with name libosmocore-$(PACKAGE_VERSION)-coverage/index.html The report is generated using gcov, lcov and lcov_cobertura tools and the OSMO_AC_CODE_COVERAGE macro. The osmo_ax_code_coverage.m4 is a copy of ax_code_coverage.m4 taken from autoconf-archive v2018.03.13. It was copied to avoid the additional external dependency and renamed to avoid overwriting it in case autoconf-archive is already installed as we are going to install it in $(datadir)/aclocal in order to be reused in other osmocom's projects. Closes: OS#1987 Change-Id: I6f4ffb91bd7f3dd070aa09dd16d5ad1faf130a4c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c54e666..060d081e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -357,6 +357,8 @@ else
AM_CONDITIONAL(HAVE_SSE4_1, false)
fi
+OSMO_AC_CODE_COVERAGE
+
dnl Check if the compiler supports specified GCC's built-in function
AC_DEFUN([CHECK_BUILTIN_SUPPORT], [
AC_CACHE_CHECK(