aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2013-02-13 20:22:53 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2013-04-10 16:17:13 +0200
commit9fae5ee932d9e0858f05e93379fb9f29d29beea2 (patch)
treedd1086360ff1dff3200f4191c2cf8078418e4ff9 /debian
parent74a50515246ac2fe555145a4f90ba62376efe662 (diff)
debian: Add debug packages with the debug symbols
Diffstat (limited to 'debian')
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules3
2 files changed, 9 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 1082831..dec5939 100644
--- a/debian/control
+++ b/debian/control
@@ -19,3 +19,9 @@ Section: libs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Osmocom SCCP library
+
+Package: libosmo-sccp-dbg
+Section: debug
+Architecture: any
+Depends: libosmo-sccp (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for Osmocom SCCP library
diff --git a/debian/rules b/debian/rules
index fb879ef..25c73fa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,6 +16,9 @@ VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
%:
dh --with autoreconf $@
+override_dh_strip:
+ dh_strip --dbg-package=libosmo-sccp-dbg
+
override_dh_autoreconf:
echo $(VERSION) > .tarball-version
dh_autoreconf