aboutsummaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-06-29 10:57:24 +0200
committerHarald Welte <laforge@gnumonks.org>2018-06-29 10:57:24 +0200
commite2fbd3dee43bb3d47c53514200650db41b4f5ef7 (patch)
treeac734d1bdded7790705539f101ec0f6f3898013e /examples/Makefile.am
parent7839556ca950f02e2dda48f8e10dd68e90266926 (diff)
remove "channel" layer
The "channel" layer on top of IPA client + server was introduced in 2011 but never used in any osmocom program/project so far. Contrary to the several other IPA multiplex related implementations in libosmo*, it did not deal properly with segmented IPA messages, i.e. where a single TCP segment (and hence recv/read call) does not contain a full IPA message. So rather than fixing it up and having yet another IPA related API in our libraries, let's remove it. Change-Id: I97c378750acb1637ee032fa88a968edf68d8979f
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index df13808..52f4c83 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -2,8 +2,6 @@ AM_CPPFLAGS = -I$(top_srcdir)/include
AM_CFLAGS=-Wall -g $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS)
AM_LDFLAGS = $(COVERAGE_LDFLAGS)
-SUBDIRS = channel
-
noinst_PROGRAMS = ipa-stream-client \
ipa-stream-server \
lapd-over-datagram-user \