aboutsummaryrefslogtreecommitdiffstats
path: root/lib/freesrp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/freesrp/CMakeLists.txt')
-rw-r--r--lib/freesrp/CMakeLists.txt15
1 files changed, 7 insertions, 8 deletions
diff --git a/lib/freesrp/CMakeLists.txt b/lib/freesrp/CMakeLists.txt
index 66c754b..85eb64d 100644
--- a/lib/freesrp/CMakeLists.txt
+++ b/lib/freesrp/CMakeLists.txt
@@ -21,19 +21,18 @@
# This file included, use CMake directory variables
########################################################################
-include_directories(
+target_include_directories(gnuradio-osmosdr PRIVATE
${CMAKE_CURRENT_SOURCE_DIR}
${LIBFREESRP_INCLUDE_DIRS}
)
-set(freesrp_srcs
+target_link_libraries(gnuradio-osmosdr
+ ${LIBFREESRP_LIBRARIES}
+)
+
+list(APPEND gr_osmosdr_srcs
${CMAKE_CURRENT_SOURCE_DIR}/freesrp_common.cc
${CMAKE_CURRENT_SOURCE_DIR}/freesrp_source_c.cc
${CMAKE_CURRENT_SOURCE_DIR}/freesrp_sink_c.cc
)
-
-########################################################################
-# Append gnuradio-osmosdr library sources
-########################################################################
-list(APPEND gr_osmosdr_srcs ${freesrp_srcs})
-list(APPEND gr_osmosdr_libs ${LIBFREESRP_LIBRARIES})
+set(gr_osmosdr_srcs ${gr_osmosdr_srcs} PARENT_SCOPE)