aboutsummaryrefslogtreecommitdiffstats
path: root/lib/freesrp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/freesrp/CMakeLists.txt')
-rw-r--r--lib/freesrp/CMakeLists.txt23
1 files changed, 11 insertions, 12 deletions
diff --git a/lib/freesrp/CMakeLists.txt b/lib/freesrp/CMakeLists.txt
index 46df7e4..aca0d8c 100644
--- a/lib/freesrp/CMakeLists.txt
+++ b/lib/freesrp/CMakeLists.txt
@@ -1,19 +1,19 @@
# Copyright 2012 Free Software Foundation, Inc.
#
-# This file is part of GNU Radio
+# This file is part of gr-osmosdr
#
-# GNU Radio is free software; you can redistribute it and/or modify
+# gr-osmosdr is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
#
-# GNU Radio is distributed in the hope that it will be useful,
+# gr-osmosdr is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
+# along with gr-osmosdr; see the file COPYING. If not, write to
# the Free Software Foundation, Inc., 51 Franklin Street,
# Boston, MA 02110-1301, USA.
@@ -21,19 +21,18 @@
# This file included, use CMake directory variables
########################################################################
-include_directories(
+target_include_directories(gnuradio-osmosdr PRIVATE
${CMAKE_CURRENT_SOURCE_DIR}
${LIBFREESRP_INCLUDE_DIRS}
)
-set(freesrp_srcs
+APPEND_LIB_LIST(
+ ${LIBFREESRP_LIBRARIES}
+)
+
+list(APPEND gr_osmosdr_srcs
${CMAKE_CURRENT_SOURCE_DIR}/freesrp_common.cc
${CMAKE_CURRENT_SOURCE_DIR}/freesrp_source_c.cc
${CMAKE_CURRENT_SOURCE_DIR}/freesrp_sink_c.cc
)
-
-########################################################################
-# Append gnuradio-osmosdr library sources
-########################################################################
-list(APPEND gr_osmosdr_srcs ${freesrp_srcs})
-list(APPEND gr_osmosdr_libs ${LIBFREESRP_LIBRARIES})
+set(gr_osmosdr_srcs ${gr_osmosdr_srcs} PARENT_SCOPE)