aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Csete <oz9aec@gmail.com>2019-12-08 16:07:28 +0100
committerSylvain Munaut <tnt@246tNt.com>2020-02-16 09:52:00 +0100
commit743cac795eef3cce95c87270670f383339bdbef9 (patch)
treec0ff5d7034b24d119e5b9d38683c3112f8b203d0 /lib/CMakeLists.txt
parent5d59e56ff90258e32a0606121c8dea522c45cb17 (diff)
airspyhf: Add initial support for Airspy HF+
Info: http://airspy.com/airspy-hf-plus/ From: Alexandru Csete <oz9aec@gmail.com> Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index a5ea712..d04cb1d 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -218,6 +218,14 @@ if(ENABLE_AIRSPY)
endif(ENABLE_AIRSPY)
########################################################################
+# Setup AIRSPYHF component
+########################################################################
+GR_REGISTER_COMPONENT("AIRSPY HF+ Receiver" ENABLE_AIRSPYHF LIBAIRSPYHF_FOUND)
+if(ENABLE_AIRSPYHF)
+ add_subdirectory(airspyhf)
+endif(ENABLE_AIRSPYHF)
+
+########################################################################
# Setup SoapySDR component
########################################################################
GR_REGISTER_COMPONENT("SoapySDR support" ENABLE_SOAPY SoapySDR_FOUND)