aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2014-08-25 23:00:47 +0200
committerSylvain Munaut <tnt@246tNt.com>2014-08-25 23:06:59 +0200
commitb7fc92ef58470c5438ba2fcc21b3d2a863f85c54 (patch)
tree2cabca0a3a94c09f192d3c9f3c55710ef27c5189 /CMakeLists.txt
parente2ce8e9a5c5a574747db7741626d71652e24b21e (diff)
gr-fosphor: CMake updates
- Update the GrXXX modules from the GNURadio counter parts - Remove the included FindGnuradio and rely on the installed one (force 3.7.3 since previous ones are broken) Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e72641..72c67f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,7 +121,7 @@ endif (QT_FOUND)
# Find gnuradio build dependencies
########################################################################
set(GR_REQUIRED_COMPONENTS RUNTIME FFT)
-find_package(Gnuradio 3.7.2 REQUIRED)
+find_package(Gnuradio 3.7.3 REQUIRED)
find_package(CppUnit)
if(NOT CPPUNIT_FOUND)
@@ -175,6 +175,7 @@ include_directories(
link_directories(
${Boost_LIBRARY_DIRS}
${CPPUNIT_LIBRARY_DIRS}
+ ${GNURADIO_ALL_LIBRARY_DIRS}
)
# Set component parameters