aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2d21abb..555899c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -12,6 +12,7 @@ AM_CFLAGS = \
check_PROGRAMS = \
procqueue/pq_test \
+ io/pq_file_test \
$(NULL)
procqueue_pq_test_SOURCES = procqueue/pq_test.c
@@ -22,6 +23,14 @@ procqueue_pq_test_LDADD = \
$(TALLOC_LIBS) \
$(NULL)
+io_pq_file_test_SOURCES = io/pq_file_test.c
+io_pq_file_test_LDADD = \
+ $(top_builddir)/src/libosmogapk.la \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOCODEC_LIBS) \
+ $(TALLOC_LIBS) \
+ $(NULL)
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
@@ -48,6 +57,8 @@ EXTRA_DIST = \
EXTRA_DIST += \
procqueue/pq_test.ok \
+ io/pq_file_test.ok \
+ io/io_sample.txt \
$(NULL)
DISTCLEANFILES = atconfig