aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2017-09-12 19:07:52 +0300
committerVadim Yanitskiy <axilirator@gmail.com>2017-12-31 12:21:00 +0100
commit3e9e57fb400218a74c44f9e3ffb70cf5291410a4 (patch)
tree5c076e2f4ef5c9d10c9160b694198e230e4f3717 /tests/Makefile.am
parent1fe6a9b9ed92da4845f8c8cef10372a3e711a8ca (diff)
tests: add pq_file test
This test is intended to check the file source / sink operability. To do that, the following processing chain is being composed: source/file -> proc/dummy -> sink/file (stdout) The source item opens the sample file named 'io_sample.txt' for reading. The next processing item simply converts all uppercase latters to the lowercase. The last one writes the result to stdout. This processing cycle is being repeated several times with different block length values.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2d21abb..555899c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -12,6 +12,7 @@ AM_CFLAGS = \
check_PROGRAMS = \
procqueue/pq_test \
+ io/pq_file_test \
$(NULL)
procqueue_pq_test_SOURCES = procqueue/pq_test.c
@@ -22,6 +23,14 @@ procqueue_pq_test_LDADD = \
$(TALLOC_LIBS) \
$(NULL)
+io_pq_file_test_SOURCES = io/pq_file_test.c
+io_pq_file_test_LDADD = \
+ $(top_builddir)/src/libosmogapk.la \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOCODEC_LIBS) \
+ $(TALLOC_LIBS) \
+ $(NULL)
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
@@ -48,6 +57,8 @@ EXTRA_DIST = \
EXTRA_DIST += \
procqueue/pq_test.ok \
+ io/pq_file_test.ok \
+ io/io_sample.txt \
$(NULL)
DISTCLEANFILES = atconfig