aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2018-06-29 19:02:26 +0700
committerVadim Yanitskiy <axilirator@gmail.com>2018-06-29 20:54:04 +0700
commit3f22f18790707d1e0baf37a76cae1217f505bfde (patch)
tree7c115b1343ace94931d75ab3993cc1535b743235 /src/Makefile.am
parent6d0156b89a49bc4f482f55fb432375d04d449008 (diff)
Implement ECU (Error Concealment Unit) block for FR
In I06a21f60db01bfe1c2b838f93866fad1d53fdcd1 the Error Concealment Unit API for FR codec was introduced. This change implements a corresponding block. Note: at the moment, only Full Rate is supported by the ECU API. Change-Id: Ia929ee04f6be3d842c6ef7bc40cce0fdab16e90a
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 50ffda4..8fdeff7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -43,6 +43,12 @@ libosmogapk_la_SOURCES = \
pq_file.c \
pq_alsa.c \
pq_rtp.c \
+ pq_ecu.c \
+ $(NULL)
+
+# ECU (Error Concealment Unit) implementation
+libosmogapk_la_SOURCES += \
+ ecu_fr.c \
$(NULL)
# Formats implementation