aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-05-20 22:30:05 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2006-05-20 22:30:05 +0000
commite0162250d97b927aa58ba6a6ab277bad65513c99 (patch)
tree7c43923b6273696bef0153e62cf8af662b8d1805 /configure.ac
parenteb4fd3a539bd3268e93a2c51977e57f355e57395 (diff)
Add support for logging CDR recrods to a radius server (issue #6639, phsultan)
- with contributions from miconda, jcollie, and sb - branch maintained by oej Thanks everyone! git-svn-id: http://svn.digium.com/svn/asterisk/trunk@29094 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 14 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 832e7ec41..1482aaa76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,6 +198,7 @@ AST_EXT_LIB([ogg], [ogg_sync_init], [], [OGG], [OGG])
AST_EXT_LIB([osptk], [OSPPCryptoDecrypt], [osp/osp.h], [OSPTK], [OSP Toolkit], [-lcrypto -lssl])
AST_EXT_LIB([popt], [poptStrerror], [popt.h], [POPT], [popt])
AST_EXT_LIB([pri], [pri_call], [libpri.h], [LIBPRI], [ISDN PRI])
+AST_EXT_LIB([radiusclient-ng], [rc_read_config], [radiusclient-ng.h], [RADIUSCLIENT], [Radius Client])
AST_EXT_LIB([speex], [speex_encode], [speex/speex.h], [SPEEX], [Speex], [-lm])
AST_EXT_LIB([sqlite], [sqlite_exec], [sqlite.h], [SQLITE], [SQLite])
AST_EXT_LIB([ssl], [ssl2_connect], [openssl/ssl.h], [OPENSSL], [OpenSSL], [-lcrypto])
@@ -208,38 +209,38 @@ AST_EXT_LIB([vorbis], [vorbis_info_init], [vorbis/codec.h], [VORBIS], [Vorbis],
AST_EXT_LIB([z], [compress], [zlib.h], [ZLIB], [zlib])
EDITLINE_LIBS=""
-if test "x$termcap_LIB" != "x" ; then
- EDITLINE_LIBS="$termcap_LIB"
-elif test "x$tinfo_LIB" != "x" ; then
- EDITLINE_LIBS="$tinfo_LIB"
-elif test "x$curses_LIB" != "x" ; then
- EDITLINE_LIBS="$curses_LIB"
-elif test "x$ncurses_LIB" != "x" ; then
- EDITLINE_LIBS="$ncurses_LIB"
+if test "x$TERMCAP_LIB" != "x" ; then
+ EDITLINE_LIBS="$TERMCAP_LIB"
+elif test "x$TINFO_LIB" != "x" ; then
+ EDITLINE_LIBS="$TINFO_LIB"
+elif test "x$CURSES_LIB" != "x" ; then
+ EDITLINE_LIBS="$CURSES_LIB"
+elif test "x$NCURSES_LIB" != "x" ; then
+ EDITLINE_LIBS="$NCURSES_LIB"
else
echo "*** termcap support not found"
exit 1
fi
AC_SUBST(EDITLINE_LIBS)
-PBX_LIBossaudio=0
+PBX_LIBOSS=0
AC_CHECK_HEADER([linux/soundcard.h],
[
- PBX_LIBossaudio=1
+ PBX_LIBOSS=1
AC_DEFINE_UNQUOTED([HAVE_OSS], 1, [Define to indicate the Open Sound System library])
])
-if test "$PBX_LIBossaudio" = "0"; then
+if test "$PBX_LIBOSS" = "0"; then
AC_CHECK_HEADER([sys/soundcard.h],
[
PBX_LIBossaudio=1
AC_DEFINE_UNQUOTED([HAVE_OSS], 1, [Define to indicate the Open Sound System library])
])
fi
-if test "$PBX_LIBossaudio" = "0"; then
+if test "$PBX_LIBOSS" = "0"; then
AST_EXT_LIB([ossaudio], [oss_ioctl_mixer], [soundcard.h], [OSS], [Open Sound System])
fi
-AC_SUBST([PBX_LIBossaudio])
+AC_SUBST([PBX_LIBOSS])
if test "${PBX_OSTYPE}" = "Linux" ; then
AST_EXT_LIB([tonezone], [tone_zone_find], [linux/zaptel.h], [ZAPTEL], [Zaptel])