aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2009-09-10 18:17:14 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2009-09-10 18:17:14 +0000
commitda7e05ef35cd6a4b9cb539ff5cff765beb278984 (patch)
tree56a363d8fd12876ed31c7a13b03b741321ca774b /configure.ac
parenta97e99188d161efb52578cc255a19da129cd7815 (diff)
Verify support for wide ODBC character types before using them.
(closes issue #15870) Reported by: nic_bellamy git-svn-id: http://svn.digium.com/svn/asterisk/trunk@217638 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 47427699a..dbcd49d7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1653,6 +1653,20 @@ else
fi
AC_SUBST(EDITLINE_LIB)
+if test "x${PBX_UNIXODBC}" = "x1" -o "x${PBX_IODBC}" = "x1"; then
+ # Does ODBC support wide characters?
+ AC_MSG_CHECKING(whether ODBC has support for Unicode types)
+ AC_LINK_IFELSE(
+ AC_LANG_PROGRAM(
+ [#include <sql.h>
+#include <sqlext.h>],
+ [int foo = SQL_WCHAR]),
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_ODBC_WCHAR], [1], [Define to 1 if your ODBC library has wide (Unicode) types.]),
+ AC_MSG_RESULT(no)
+ )
+fi
+
AC_CHECK_HEADER([h323.h], [PBX_H323=1], [PBX_H323=0])
AC_SUBST(PBX_H323)