aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-03-17 00:14:29 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-03-17 00:14:29 +0000
commitabbeaec6b3be27ff95ff56f85674bc2d9f94fa59 (patch)
tree111161c056abd36215537b8c7962d6d0d2dfad72 /configure.ac
parentc98856539ac7851b88b89bbaffad2ce634e20050 (diff)
Fix bamboo compile error by calculating an integer with the same size as a pointer.
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@252980 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5a4aac7fe..057327a09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -780,7 +780,10 @@ AST_C_DEFINE_CHECK([IP_MTU_DISCOVER], [IP_MTU_DISCOVER], [netinet/in.h])
AC_CHECK_HEADER([libkern/OSAtomic.h],
[AC_DEFINE_UNQUOTED([HAVE_OSX_ATOMICS], 1, [Define to 1 if OSX atomic operations are supported.])])
-AC_CHECK_SIZEOF(int)
+AC_CHECK_SIZEOF([int])
+AC_CHECK_SIZEOF([long])
+AC_CHECK_SIZEOF([long long])
+AC_CHECK_SIZEOF([char *])
# do the package library checks now