aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-07-16 04:45:33 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-07-16 04:45:33 +0000
commit9e41a69ae825595ae8db890ed5ce1ccdfb778443 (patch)
tree72266dc4ed9ed204bec5b582f99fdb1774c06b3a /configure.ac
parent34a5c533f35e7b88c7da713e5186c42381324fa1 (diff)
Fix build on FreeBSD
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@276871 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4bfac0af8..8d69691b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -480,6 +480,19 @@ AC_LINK_IFELSE(
AC_MSG_RESULT(no)
)
+AC_MSG_CHECKING(for a version of GNU ld that supports the --dynamic-list flag)
+old_LDFLAGS=${LDFLAGS}
+LDFLAGS+="-Wl,--dynamic-list,main/asterisk.dynamics"
+PBX_DYNAMIC_LIST=0
+AC_LINK_IFELSE(
+ AC_LANG_PROGRAM([], []),
+ PBX_DYNAMIC_LIST=1
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+AC_SUBST(PBX_DYNAMIC_LIST)
+LDFLAGS=${old_LDFLAGS}
+
AC_CHECK_HEADER([sys/poll.h],
[HAS_POLL=1]
AC_DEFINE([HAVE_SYS_POLL_H], 1, [Define to 1 if your system has working sys/poll.h]),