aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authordbailey <dbailey@f38db490-d61c-443f-a65b-d21fe96a405b>2009-04-21 14:28:04 +0000
committerdbailey <dbailey@f38db490-d61c-443f-a65b-d21fe96a405b>2009-04-21 14:28:04 +0000
commit7c52f6382400efab455ef18e41e68e025d6644d7 (patch)
tree9769d3d121d4fa2d64c6408c531cd3e24ff7c5ba /configure.ac
parent0c2ed9560d16a5a2dfc444504b1bc794de4f68b5 (diff)
Merged revisions 189601 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r189601 | dbailey | 2009-04-21 09:00:55 -0500 (Tue, 21 Apr 2009) | 3 lines Add check in configure script to check for GLOB_NOMAGIC and GLOB_BRACE in glob.h This allows config.c to compile when linked against uclibc that does not support these parameters ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@189629 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00220d238..6fff95fb9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -609,6 +609,10 @@ AC_LINK_IFELSE(
AC_MSG_RESULT(no)
)
+AST_C_DEFINE_CHECK([GLOB_NOMAGIC], [GLOB_NOMAGIC], [glob.h])
+
+AST_C_DEFINE_CHECK([GLOB_BRACE], [GLOB_BRACE], [glob.h])
+
AST_C_DEFINE_CHECK([IP_MTU_DISCOVER], [IP_MTU_DISCOVER], [netinet/in.h])
AC_CHECK_HEADER([libkern/OSAtomic.h],