aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2009-06-16 21:02:05 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2009-06-16 21:02:05 +0000
commit78ca164fe19251dde45530f5fbe8fcf4d5ceed27 (patch)
tree50faeb17b22404e86c6409ee502abbf44d3715d0 /configure.ac
parent14da66c6a0f905961c92d9eeb37a991f76ce0c0f (diff)
Explicitly test for 'static weakref' support.
Since we use 'static' weakref symbols, and not all GCC versions support them, test for that combination explicitly. git-svn-id: http://svn.digium.com/svn/asterisk/trunk@201137 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cfb53fd7f..a9379c3ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -514,7 +514,7 @@ AST_GCC_ATTRIBUTE(always_inline)
AST_GCC_ATTRIBUTE(deprecated)
AST_GCC_ATTRIBUTE(sentinel)
AST_GCC_ATTRIBUTE(warn_unused_result)
-AST_GCC_ATTRIBUTE(weakref, [weakref("foo")])
+AST_GCC_ATTRIBUTE(weakref, [weakref("foo")], static)
AST_GCC_ATTRIBUTE(weak_import)
AC_MSG_CHECKING(for -ffunction-sections support)