aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2009-06-26 22:08:05 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2009-06-26 22:08:05 +0000
commit78c6aec64bbe3382ea89fb0f5c0f1bdaa0685676 (patch)
tree0f80b453deb9a62e9a7f8cd831e1e7232dbb1805 /configure.ac
parent23cd457af9ee919ce3abe7f2c1f77b2dfe279d91 (diff)
Add a new module, cdr_syslog, which allows writing CDRs to syslog.
The original patch for this was written by Brett Bryant, and I split it out into it's own module. (closes issue #12876) Reported by: bbryant Patches: 06162008_cdr_custom_syslog.diff uploaded by bbryant (license 36) 05212009_cdr_syslog.patch uploaded by seanbright (license 71) Tested by: seanbright Review: https://reviewboard.asterisk.org/r/297/ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@203846 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 27e1323b7..4ea4236a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1747,6 +1747,8 @@ AC_SUBST([GENERIC_ODBC_LIB])
AC_SUBST([GENERIC_ODBC_INCLUDE])
AC_SUBST([PBX_GENERIC_ODBC])
+PBX_SYSLOG=0
+
if test "${ac_cv_header_syslog_h}" = "yes"; then
# syslog facilities
AST_C_DEFINE_CHECK([SYSLOG_FACILITY_LOG_AUTH], [LOG_AUTH], [syslog.h])
@@ -1760,8 +1762,11 @@ if test "${ac_cv_header_syslog_h}" = "yes"; then
AST_C_DEFINE_CHECK([SYSLOG_FACILITY_LOG_NEWS], [LOG_NEWS], [syslog.h])
AST_C_DEFINE_CHECK([SYSLOG_FACILITY_LOG_SYSLOG], [LOG_SYSLOG], [syslog.h])
AST_C_DEFINE_CHECK([SYSLOG_FACILITY_LOG_UUCP], [LOG_UUCP], [syslog.h])
+ PBX_SYSLOG=1
fi
+AC_SUBST([PBX_SYSLOG])
+
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts channels/h323/Makefile])
AST_CHECK_MANDATORY