aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2009-08-28 20:01:21 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2009-08-28 20:01:21 +0000
commit63cc27ace80a273b5c183decb10ca26019230b1f (patch)
tree94a3fc2d8afe760a93e732a57af1b8f082bc47c5 /configure.ac
parent97c3f0762e601deeecec2511823c0df60c0a825b (diff)
Ensure that CFLAGS and/or LDFLAGS provided to configure script are preserved.
Cross-compilation environments want to provide 'defaults' for compiler and linker options, and frequently do this by specifying CFLAGS and LDFLAGS in the environment or as command-line arguments to the configure script. This patch modifies the configure script and Makefile to preserve these settings and ensure they are used in the build process. git-svn-id: http://svn.digium.com/svn/asterisk/trunk@214696 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 37bb2010a..c7ae196cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,12 @@ AC_REVISION($Revision$)
AC_USE_SYSTEM_EXTENSIONS # note- does not work on FreeBSD
+# preserve any CFLAGS or LDFLAGS that may be set
+CONFIG_CFLAGS="${CFLAGS}"
+CONFIG_LDFLAGS="${LDFLAGS}"
+AC_SUBST(CONFIG_CFLAGS)
+AC_SUBST(CONFIG_LDFLAGS)
+
case "${host_os}" in
freebsd*)
ac_default_prefix=/usr/local