aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2009-07-08 16:43:12 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2009-07-08 16:43:12 +0000
commit5b4529e89e691d357eba13683c4286fc5faa3602 (patch)
treeaa1d72bc8ed6c1daa7aba2135487d4db3129f8b0 /configure.ac
parent7c0bbc9c8de18333ef0717ac71f22285b01a833d (diff)
Fix a few compilation problems found when building Asterisk against uClibc.
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@205214 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dceec8158..38c43ca27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -626,6 +626,25 @@ AC_LINK_IFELSE(
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_RES_NDESTROY], 1, [Define to 1 if your system has the ndestroy resolver function.]),
AC_MSG_RESULT(no)
+ )
+ AC_SEARCH_LIBS(res_9_close, resolv)
+ AC_MSG_CHECKING(for res_close)
+ AC_LINK_IFELSE(
+ AC_LANG_PROGRAM([
+ #ifdef HAVE_SYS_SOCKET_H
+ #include <sys/socket.h>
+ #endif
+ #ifdef HAVE_NETINET_IN_H
+ #include <netinet/in.h>
+ #endif
+ #ifdef HAVE_ARPA_NAMESER_H
+ #include <arpa/nameser.h>
+ #endif
+ #include <resolv.h>],
+ [res_close();]),
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_RES_CLOSE], 1, [Define to 1 if your system has the close resolver function.]),
+ AC_MSG_RESULT(no)
),
AC_MSG_RESULT(no)
)