aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2006-11-16 20:10:59 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2006-11-16 20:10:59 +0000
commit1f207a842220670d5252d0e5337462479dfd7e06 (patch)
treee50077bb33437238afe96c5dfbb9678e410b3d4a /configure.ac
parentc4f8f8d6b3277087486cca494e02d74eca5e4c57 (diff)
Merged revisions 47758 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r47758 | kpfleming | 2006-11-16 14:09:10 -0600 (Thu, 16 Nov 2006) | 2 lines check for pre-1.4 versions of Zaptel and abort the configure script if found with an appropriate error message ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@47759 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0241bf573..f9519beb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -851,6 +851,38 @@ AST_C_DEFINE_CHECK([ZAPTEL], [ZT_TONE_DTMF_BASE], [zaptel/zaptel.h], [140])
# or, try old zaptel (0.80 or so)
AST_EXT_LIB_CHECK([ZAPTEL], [zaptel],, [zaptel.h],, [80])
+if test "${USE_ZAPTEL}" != "no"; then
+ if test "${PBX_ZAPTEL}" != "1"; then
+ AC_MSG_CHECKING(for ZT_DIAL_OP_CANCEL in zaptel.h)
+ saved_cppflags="${CPPFLAGS}"
+ if test "x${ZAPTEL_DIR}" != "x"; then
+ CPPFLAGS="${CPPFLAGS} -I${ZAPTEL_DIR}/include"
+ fi
+ AC_COMPILE_IFELSE(
+ [
+ AC_LANG_PROGRAM(
+ [#include <zaptel.h>],
+ [int foo = ZT_DIAL_OP_CANCEL;])
+ ],
+ [ AC_MSG_RESULT(yes)
+ ac_cv_zaptel_h="yes"
+ ],
+ [ AC_MSG_RESULT(no)
+ ac_cv_zaptel_h="no"
+ ]
+ )
+ CPPFLAGS="${saved_cppflags}"
+ if test "${ac_cv_zaptel_h}" = "yes"; then
+ AC_MSG_NOTICE(***)
+ AC_MSG_NOTICE(*** The Zaptel installation on this system is too old)
+ AC_MSG_NOTICE(*** to be useable with this version of Asterisk.)
+ AC_MSG_NOTICE(*** Either upgrade your Zaptel installation, or run configure)
+ AC_MSG_NOTICE(*** including --without-zaptel.)
+ exit 1
+ fi
+ fi
+fi
+
EDITLINE_LIB=""
if test "x$TERMCAP_LIB" != "x" ; then
EDITLINE_LIB="$TERMCAP_LIB"