aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/wimaxasncp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/wimaxasncp/CMakeLists.txt')
-rw-r--r--plugins/wimaxasncp/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/wimaxasncp/CMakeLists.txt b/plugins/wimaxasncp/CMakeLists.txt
index 737dbb7939..0b3700c58d 100644
--- a/plugins/wimaxasncp/CMakeLists.txt
+++ b/plugins/wimaxasncp/CMakeLists.txt
@@ -57,12 +57,13 @@ add_library(wimaxasncp ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(wimaxasncp PROPERTIES PREFIX "")
-#set_target_properties(wimaxasncp PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(wimaxasncp PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(wimaxasncp PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(wimaxasncp epan)
install(TARGETS wimaxasncp
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)