aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/profinet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/profinet/CMakeLists.txt')
-rw-r--r--plugins/profinet/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/profinet/CMakeLists.txt b/plugins/profinet/CMakeLists.txt
index 704dec9e03..affdfdd0c3 100644
--- a/plugins/profinet/CMakeLists.txt
+++ b/plugins/profinet/CMakeLists.txt
@@ -65,12 +65,13 @@ add_library(profinet ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(profinet PROPERTIES PREFIX "")
-#set_target_properties(profinet PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(profinet PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(profinet PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(profinet epan)
install(TARGETS profinet
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)