aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/gryphon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/gryphon/CMakeLists.txt')
-rw-r--r--plugins/gryphon/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/gryphon/CMakeLists.txt b/plugins/gryphon/CMakeLists.txt
index f847ffb1d0..395eb92d7c 100644
--- a/plugins/gryphon/CMakeLists.txt
+++ b/plugins/gryphon/CMakeLists.txt
@@ -53,12 +53,13 @@ add_library(gryphon ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(gryphon PROPERTIES PREFIX "")
-#set_target_properties(gryphon PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(gryphon PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(gryphon PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(gryphon epan)
install(TARGETS gryphon
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)