aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/ethercat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ethercat/Makefile.am')
-rw-r--r--plugins/ethercat/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/plugins/ethercat/Makefile.am b/plugins/ethercat/Makefile.am
index 70bf2a7e0c..3605caffdc 100644
--- a/plugins/ethercat/Makefile.am
+++ b/plugins/ethercat/Makefile.am
@@ -24,6 +24,9 @@ include ../Makefile.am.inc
# the name of the plugin
PLUGIN_NAME = ethercat
+BUILT_SOURCES = \
+ plugin.c
+
# Non-generated sources to be scanned for registration routines
NONGENERATED_REGISTER_C_FILES = \
packet-ams.c \
@@ -53,11 +56,13 @@ HEADER_FILES = \
plugin_LTLIBRARIES = ethercat.la
ethercat_la_SOURCES = \
- plugin.c \
moduleinfo.h \
$(SRC_FILES) \
$(HEADER_FILES)
+nodist_ethercat_la_SOURCES = \
+ plugin.c
+
ethercat_la_CPPFLAGS = $(AM_CPPFLAGS) $(PLUGIN_CPPFLAGS)
ethercat_la_CFLAGS = $(AM_CFLAGS) $(PLUGIN_CFLAGS)