aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/docsis/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/docsis/CMakeLists.txt')
-rw-r--r--plugins/docsis/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/plugins/docsis/CMakeLists.txt b/plugins/docsis/CMakeLists.txt
index 2847468e54..e30973844c 100644
--- a/plugins/docsis/CMakeLists.txt
+++ b/plugins/docsis/CMakeLists.txt
@@ -87,13 +87,13 @@ add_library(docsis ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(docsis PROPERTIES PREFIX "")
-#set_target_properties(docsis PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
-
+set_target_properties(docsis PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(docsis PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(docsis epan)
install(TARGETS docsis
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)