aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f1f9cf0e4..5a1a585d71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,6 +243,9 @@ if(BUILD_wireshark)
set(GTK2_FIND_VERSION 2.12)
set(GTK2_DEBUG false)
endif()
+ if(ENABLE_THREADS)
+ set(PACKAGELIST ${PACKAGELIST} GTHREAD2)
+ endif()
endif()
if(BUILD_dumpcap)
@@ -667,6 +670,9 @@ if(BUILD_wireshark AND GTK_FOUND)
${APPLE_CORE_SERVICES_LIBRARY}
${APPLE_COCOA_LIBRARY}
)
+ if(ENABLE_THREADS)
+ set(wireshark_LIBS ${wireshark_LIBS} ${GTHREAD2_LIBRARIES})
+ endif()
set(wireshark_FILES
airpcap_loader.c
alert_box.c