aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2008-05-23 02:09:48 +0000
committerGuy Harris <guy@alum.mit.edu>2008-05-23 02:09:48 +0000
commit819dc6c790b06163ce6c50dc00f4b3ca0cb8d201 (patch)
tree57bfc58f14106629b28ac4d6f6412464bf197c56 /wsutil/Makefile.am
parent60d4c486f92dde4856dec601532d8d21d4977060 (diff)
Add a Makefile.common file, and have Makefile.am and Makefile.nmake use it.
svn path=/trunk/; revision=25360
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index 07a0b5acac..ee8459f727 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -6,7 +6,6 @@
# By Gerald Combs <gerald@wireshark.org>
# Copyright 1998 Gerald Combs
#
-#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
@@ -21,6 +20,10 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ACLOCAL_AMFLAGS = `../aclocal-flags`
+
+include Makefile.common
+
if HAVE_WARNINGS_AS_ERRORS
AM_CFLAGS = -Werror
endif
@@ -30,14 +33,14 @@ lib_LTLIBRARIES = libwsutil.la
INCLUDES = -I$(srcdir)/..
libwsutil_la_SOURCES = \
- mpeg-audio.c \
- mpeg-audio.h
+ $(LIBWSUTIL_SRC) \
+ $(LIBWSUTIL_INCLUDES)
libwsutil_la_LIBADD = @GLIB_LIBS@
EXTRA_DIST = \
- Makefile.nmake \
- file_util.c
+ Makefile.common \
+ Makefile.nmake
CLEANFILES = \
libwsutil.a \