aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2010-05-29 03:33:28 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2010-05-29 03:33:28 +0000
commit403e4e62a4147a0d8b9009413fdf5b67f3242d0d (patch)
tree993381258163cbced0bd44746432785126cb005f /wsutil/Makefile.am
parentbaee0e77feae24cd70139aef9083b4c260e01c0a (diff)
Put the optional objects in EXTRA..SOURCES instead of EXTRA_DIST.
Put the optional objects in a _DEPENDENCIES rule so they actually get built when needed. Use libtool to make these objects. Remove AC variables that are no longer needed. svn path=/trunk/; revision=33017
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am38
1 files changed, 21 insertions, 17 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index e4d42bd6d4..a813ee5ab7 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -31,12 +31,13 @@ endif
# Optional objects that I know how to build. These will be
# linked into libwsutil.
wsutil_optional_objects = \
- @GETOPT_O@ \
- @STRERROR_O@ \
- @STRNCASECMP_O@ \
- @STRPTIME_O@ \
+ @GETOPT_LO@ \
+ @INET_ATON_LO@ \
+ @INET_NTOP_LO@ \
@INET_PTON_LO@ \
- @INET_NTOP_LO@
+ @STRERROR_LO@ \
+ @STRNCASECMP_LO@ \
+ @STRPTIME_LO@
lib_LTLIBRARIES = libwsutil.la
@@ -48,7 +49,20 @@ libwsutil_la_SOURCES = \
EXTRA_libwsutil_la_SOURCES= \
inet_aton.c \
- inet_aton.h
+ inet_aton.h \
+ inet_ntop.c \
+ inet_pton.c \
+ inet_v6defs.h \
+ strerror.c \
+ strerror.h \
+ strncasecmp.c \
+ strptime.c \
+ strptime.h \
+ wsgetopt.c \
+ wsgetopt.h
+
+libwsutil_la_DEPENDENCIES= \
+ $(wsutil_optional_objects)
libwsutil_la_LIBADD = \
@GLIB_LIBS@ \
@@ -59,19 +73,9 @@ EXTRA_DIST = \
Makefile.nmake \
file_util.c \
file_util.h \
- inet_ntop.c \
- inet_pton.c \
- inet_v6defs.h \
libwsutil.def \
- strerror.c \
- strerror.h \
- strncasecmp.c \
- strptime.c \
- strptime.h \
unicode-utils.c \
- unicode-utils.h \
- wsgetopt.c \
- wsgetopt.h
+ unicode-utils.h
CLEANFILES = \
libwsutil.a \