aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-19 08:03:08 +0100
committerJoão Valverde <j@v6e.pt>2016-04-21 18:59:56 +0000
commit3db13a7fc9f08fdb238f06e73a42b39396fee84c (patch)
tree13962d67e01b8d0f15aed5e6216ae584c23bd991 /wsutil/CMakeLists.txt
parent7c6e859ccf210a45e1cc0f6da17692845e6b5a23 (diff)
Link version code statically again
This allows keeping the code-sharing with the static linking. This "fixes" a hypothetical ABI mismatch with wsutil and avoids pulling more external dependencies to wsutil than strictly necessary. A nice side-effect is that libwsutil no longer depends on version.h. Follow up to f95976eefcbeb5d24df383c29d29ef888b503945. Change-Id: I8f0d6a557ab3f7ce6f0e2c269124c89f29d6ad23 Reviewed-on: https://code.wireshark.org/review/15002 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 9eeda808bc..209787a658 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -75,7 +75,6 @@ set(WSUTIL_FILES
type_util.c
unicode-utils.c
ws_mempbrk.c
- ws_version_info.c
${WSUTIL_PLATFORM_FILES}
)