aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2006-10-19 07:45:10 +0000
committerGuy Harris <guy@alum.mit.edu>2006-10-19 07:45:10 +0000
commite773247138e940ec0653b424011884a9d3818546 (patch)
tree007f076377fb6bf2e9dedfe8b959ac4e22a01b62 /wiretap/Makefile.am
parent4f5a48c4f62cca7b33fb5757c9538d495de99282 (diff)
If we have to use Lex or Flex, check whether we found it, first, and if
we didn't, report an error and fail, rather than blithely executing commands with the command a blank string. svn path=/trunk/; revision=19602
Diffstat (limited to 'wiretap/Makefile.am')
-rw-r--r--wiretap/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/wiretap/Makefile.am b/wiretap/Makefile.am
index 13f75887dd..8a5616384f 100644
--- a/wiretap/Makefile.am
+++ b/wiretap/Makefile.am
@@ -57,4 +57,8 @@ EXTRA_DIST = \
AM_YFLAGS=-d -p ascend
ascend-scanner.c : ascend-scanner.l
+ @if [ ! -x "$(LEX)" ]; then \
+ echo "Neither lex nor flex was found"; \
+ exit 1; \
+ fi
$(LEX) -Pascend -oascend-scanner.c $(srcdir)/ascend-scanner.l