aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2023-01-18 00:46:21 +0000
committerJoão Valverde <j@v6e.pt>2023-01-18 03:35:13 +0000
commitfe7bfdf6caac9204ab5f34eeba7b0f4a0314d3cd (patch)
tree135f1addfb0bd60441095b6122fc40fce4909115 /wiretap/CMakeLists.txt
parent728073ade057f5376f6b984115a962e8e812264b (diff)
CMake: Require explicit installation of development headers
Develpment headers are a sizeable part of the binary installation and most users won't ever require them. It's recommended to package them separately in a devel package or SDK. Create a CMake installation component for development headers and add the EXCLUDE_FROM_ALL property. Headers can be installed using the invocation: cmake --install <dir> --component Development
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 024ad4b784..1d1da81f53 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -211,6 +211,8 @@ install(TARGETS wiretap
install(FILES ${WIRETAP_PUBLIC_HEADERS}
DESTINATION "${PROJECT_INSTALL_INCLUDEDIR}/wiretap"
+ COMPONENT "Development"
+ EXCLUDE_FROM_ALL
)
CHECKAPI(