aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2023-05-27 12:16:29 +0100
committerJoão Valverde <j@v6e.pt>2023-05-27 12:49:29 +0100
commitf653e52e0fbb3c5c686af14c0f96e3fa8c59e8ff (patch)
tree468835cff44c3416451804481a53c521639ed2ce /wiretap/CMakeLists.txt
parent78efc8d7fa837bebb0a3fc8d791330b45ce417fa (diff)
CMake: Try to use FindPython3.cmake again
Use FindPython3.cmake instead of the deprecated FindPythonInterp.cmake, to make sure we actually find Python3. Don't use the module with MSYS2 because it is buggy and exhibits broken behaviour. Run it earlier in the configuration, just as a precaution, so other indirect calls to find python don't happen earlier.
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index b021208335..ff4b77ffe0 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -151,7 +151,7 @@ file(GENERATE
)
add_custom_command(
OUTPUT wtap_modules.c
- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/make-regs.py wtap_modules wtap_modules.c @wtap_modules.in.txt
+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/make-regs.py wtap_modules wtap_modules.c @wtap_modules.in.txt
DEPENDS ${CMAKE_SOURCE_DIR}/tools/make-regs.py ${WIRETAP_MODULE_FILES}
"${CMAKE_CURRENT_BINARY_DIR}/wtap_modules.in.txt"
COMMENT "Making wtap_modules.c"