aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-02-26 22:09:15 +0000
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-03-01 20:59:39 +0000
commit7f105d39813914036f6c04a2d73b315542cde322 (patch)
tree7901018f226e9c077670aa1936f54faa000eb994 /wiretap/CMakeLists.txt
parent142cfb03ac5d0473d70f3e8adeabdc4f4496e953 (diff)
CMake: Use CheckAPI's abort/termoutput with dissectors only
I believe this was the original intention, to use these API restricitons with dissectors only (not that I necessarily agree with that policy either), and through copy-paste and lack of clear guidelines it spread to other parts of the build. Rename the checkAPI groups to make it very clear that this is dissector-only. This doesn't mean, of course, that good programming practices shouldn't be followed everywhere. In particular assertions need to be used properly. Don't use them to catch runtime errors or validate input data. This commit will be followed by another removing the various ugly hacks people have been using to get around the checkAPI hammer.
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 2b119f2fe1..2598d14af6 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -202,8 +202,6 @@ CHECKAPI(
NAME
wiretap
SWITCHES
- --group abort:11 --summary-group abort
- --group termoutput:1 --summary-group termoutput
SOURCES
${WIRETAP_NONGENERATED_FILES}
# LEX files commented out due to use of malloc, free etc.