aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2018-11-23 20:39:48 +0000
committerJoão Valverde <j@v6e.pt>2018-11-24 13:48:16 +0000
commit65c13f9b900cec51c4117c848bee045c9cecd35f (patch)
tree153021770405714b67432ecd1beeea33329c8820 /wiretap/CMakeLists.txt
parentf1cf2646aa44fe0f56019906d0edbc49253ececa (diff)
Install development headers on all platforms
Install headers to support plugins development on Windows. Change-Id: I3161bd2f730edf62ab44fee6ce4fedbb9aee0d31 Reviewed-on: https://code.wireshark.org/review/30776 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index cbf94aa396..ac4eafee76 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -162,11 +162,9 @@ install(TARGETS wiretap
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)
-if(NOT WIN32)
- install(FILES ${WIRETAP_PUBLIC_HEADERS}
- DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/${CPACK_PACKAGE_NAME}/wiretap"
- )
-endif()
+install(FILES ${WIRETAP_PUBLIC_HEADERS}
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/${CPACK_PACKAGE_NAME}/wiretap"
+)
CHECKAPI(
NAME