aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <gharris@sonic.net>2021-02-22 03:37:51 -0800
committerGuy Harris <gharris@sonic.net>2021-02-22 19:45:44 +0000
commit00d266145904cfa08045984853aecf06a55115c8 (patch)
tree39b53d7a06064db72ab130b206ac25b81fd8941a /wiretap/CMakeLists.txt
parent3a25ebbc42d5fd2e1c42e61154ffeebc2a28ef64 (diff)
wiretap: fix dependency in CMakeLists.txt.
wtap_modules.c depends on ${WIRETAP_MODULE_FILES} rather than ${WIRETAP_NONGENERATED_FILES}.
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 858769ac56..406bbf1352 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -141,7 +141,7 @@ file(GENERATE
add_custom_command(
OUTPUT wtap_modules.c
COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/make-regs.py wtap_modules wtap_modules.c @wtap_modules.in.txt
- DEPENDS ${CMAKE_SOURCE_DIR}/tools/make-regs.py ${WIRETAP_NONGENERATED_FILES}
+ DEPENDS ${CMAKE_SOURCE_DIR}/tools/make-regs.py ${WIRETAP_MODULE_FILES}
"${CMAKE_CURRENT_BINARY_DIR}/wtap_modules.in.txt"
COMMENT "Making wtap_modules.c"
)