aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-10-28 18:01:09 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-10-28 18:01:09 +0000
commitd07f872c90ddc6bb9492960e934b7222806b2ed1 (patch)
tree492b8c4bf086d2ae20c039500d8aacf255f935da /ui/qt/Makefile.am
parent558725067675ac6d0e6f9421a971c7f8ad18776f (diff)
From Peter Wu via https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9341 :
SVN rev 50525 tried to fix out-of-source-tree builds, but did so by writing the .rcc.cpp files to the source tree. This was noticed when running `make distcheck`. This patch reverts that behavior, and creates the image/ directory to fix out-of-tree builds. In other words, fix things so "make distcheck" with Qt works in out-of-tree builds too. svn path=/trunk/; revision=52926
Diffstat (limited to 'ui/qt/Makefile.am')
-rw-r--r--ui/qt/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/ui/qt/Makefile.am b/ui/qt/Makefile.am
index 8715f9d316..142b297e91 100644
--- a/ui/qt/Makefile.am
+++ b/ui/qt/Makefile.am
@@ -89,6 +89,7 @@ SUFFIXES = .moc.cpp .qrc .rcc.cpp
$(AM_V_MOC)$(MOC) -I.. -I../.. -o $@ $<
.qrc.rcc.cpp:
+ $(MKDIR_P) $(@D)
$(AM_V_RCC)rcc -name `basename $< .qrc` -o $@ $<
ui_%.h: %.ui