aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2017-07-09 02:15:25 +0200
committerAnders Broman <a.broman58@gmail.com>2017-07-15 06:17:38 +0000
commitb992e69c19a4fac968ef7a95d0c439638687a72d (patch)
tree5a4d2f48489ece29e295717a356d7dbb9b336824 /ui/qt/CMakeLists.txt
parentbc7198e40e21c81a36a06f1c5566160e395eb0a5 (diff)
Qt: implement saner tab navigation for coloring rules dialog
The default QTreeView/QTreeWidget behavior for (Shift-)Tab navigation is to select the previous/next row. For data entries with multiple columns (such as the UAT dialog or the coloring rules dialog), column navigation is closer to what a user would expect, so implement that. Bug: 13856 Change-Id: Ib585030380f894e0be214a95107cb264afac7eee Reviewed-on: https://code.wireshark.org/review/22561 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 085dc9a635..1ddcacf3a9 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -161,6 +161,7 @@ set(WIRESHARK_QT_HEADERS
simple_statistics_dialog.h
stock_icon_tool_button.h
supported_protocols_dialog.h
+ tabnav_tree_widget.h
tap_parameter_dialog.h
tcp_stream_dialog.h
time_shift_dialog.h
@@ -340,6 +341,7 @@ set(WIRESHARK_QT_SRC
stock_icon.cpp
stock_icon_tool_button.cpp
supported_protocols_dialog.cpp
+ tabnav_tree_widget.cpp
tap_parameter_dialog.cpp
tcp_stream_dialog.cpp
time_shift_dialog.cpp