aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-09-10 14:42:07 -0700
committerGerald Combs <gerald@wireshark.org>2015-09-11 15:27:21 +0000
commitb55ae49ba1947ae5cbf8ad12ff3b8855a5fd7813 (patch)
treeb5c6c723a66d803b1c61b4602dd1b9bc835660cf /ui/qt/CMakeLists.txt
parent5a3ad8fe06f12fc68ccb99a2b1ebd90e2bbf263c (diff)
Make StockIconToolButton independent.
A recent set of changes replaced the "dfilter_erase_" images with an "x-filter-clear" stock icon set. Move StockIconToolButton to its own compilation unit. Use it in CaptureFilterEdit and ProgressFrame to load the "x-filter-clear" icon. Bug: 11516 Change-Id: I5d5864d089fb56827d130d493d53e7de6a7c03b5 Reviewed-on: https://code.wireshark.org/review/10475 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 2e6c0c47bf..ea95d7d22e 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -125,6 +125,7 @@ set(WIRESHARK_QT_HEADERS
stats_tree_dialog.h
service_response_time_dialog.h
simple_statistics_dialog.h
+ stock_icon_tool_button.h
syntax_line_edit.h
tap_parameter_dialog.h
tcp_stream_dialog.h
@@ -259,6 +260,7 @@ set(WIRESHARK_QT_SRC
splash_overlay.cpp
sparkline_delegate.cpp
stock_icon.cpp
+ stock_icon_tool_button.cpp
syntax_line_edit.cpp
tap_parameter_dialog.cpp
tcp_stream_dialog.cpp