aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2017-11-29 17:25:53 -0800
committerGerald Combs <gerald@wireshark.org>2017-12-05 18:27:23 +0000
commitabcb7ec8750a263d0307bc41d86b798e5ae02966 (patch)
tree6d37d9e65a4e93ae9f775b664d429b1fde064796 /ui/qt/CMakeLists.txt
parent5eb07b35d430b68c6d816476190035e0774f18d2 (diff)
Convert the file set dialog treewidget to a treeview+model.
Add a FilesetEntryModel and use it in FileSetDialog. This should be faster than using a QTreeWidget. Move dialog updates and date calculations out of the "add file" loop. Bug: 11280 Bug: 14242 Change-Id: I702cef4fe91e739695fe805dc5e496bf3db411f1 Reviewed-on: https://code.wireshark.org/review/24708 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 19496e154a..7be83ddbe4 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -64,6 +64,7 @@ set(WIRESHARK_MODEL_HEADERS
models/cache_proxy_model.h
models/decode_as_delegate.h
models/decode_as_model.h
+ models/fileset_entry_model.h
models/html_text_delegate.h
models/interface_sort_filter_model.h
models/interface_tree_cache_model.h
@@ -270,6 +271,7 @@ set(WIRESHARK_MODEL_SRCS
models/cache_proxy_model.cpp
models/decode_as_delegate.cpp
models/decode_as_model.cpp
+ models/fileset_entry_model.cpp
models/html_text_delegate.cpp
models/interface_sort_filter_model.cpp
models/interface_tree_cache_model.cpp