aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-09-30 16:54:40 -0700
committerGerald Combs <gerald@wireshark.org>2015-10-01 17:25:28 +0000
commita013823934b437c43960959ee725858e1b75ed15 (patch)
tree3e7246733dd48eff2a320a83c01baed81b182d93 /ui/qt/CMakeLists.txt
parent6193e3c74b9a5d4296c67cbb138f231861d56fba (diff)
Add the conversation hash tables internals dialog.
The GTK+ version dumps "new" and "old" hash values. It looks like neither are valid since the code in conversation.c and conversation_hashtables_dlg.c have diverged. For now just dump the addresses and ports for each hash table in the Qt UI. Change-Id: I832522dff06da769bd4ad3ead3d541206f283a90 Reviewed-on: https://code.wireshark.org/review/10713 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index ae7d48b57c..7be8a8fce1 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -46,6 +46,7 @@ set(WIRESHARK_QT_HEADERS
column_editor_frame.h
compiled_filter_output.h
conversation_dialog.h
+ conversation_hash_tables_dialog.h
decode_as_dialog.h
display_filter_combo.h
display_filter_edit.h
@@ -190,6 +191,7 @@ set(WIRESHARK_QT_SRC
column_editor_frame.cpp
compiled_filter_output.cpp
conversation_dialog.cpp
+ conversation_hash_tables_dialog.cpp
decode_as_dialog.cpp
display_filter_combo.cpp
display_filter_edit.cpp
@@ -330,6 +332,7 @@ set(WIRESHARK_QT_UI
column_preferences_frame.ui
column_editor_frame.ui
compiled_filter_output.ui
+ conversation_hash_tables_dialog.ui
decode_as_dialog.ui
display_filter_expression_dialog.ui
dissector_tables_dialog.ui