aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2018-05-18 11:01:24 +0200
committerPeter Wu <peter@lekensteyn.nl>2018-05-18 13:25:50 +0000
commit71a240d6118c99eb2e918d71e81164808bd64a29 (patch)
treea71083d3bfd610a15d948727c5085a3d59a3fd42 /ui/qt/CMakeLists.txt
parent819696eaa736842ec8da4909bc0783611aa2f724 (diff)
cmake: remove dependency of i18n.qrc on .qm files
The i18n.qrc file is generated at cmake time while the .qm files are also built as dependency of the AUTORCC process. The extraneous .qm dependency of i18n.qrc possibly causes duplicate wireshark_zh_CN.qm builds (see v2.9.0rc0-605-g644939ed9e), so remove it. Change-Id: I629e7b809486a65b27158f66a7e62cfcf61657d3 Reviewed-on: https://code.wireshark.org/review/27633 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 15929aa1f8..7c09fca0ae 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -564,7 +564,6 @@ foreach(_file ${WIRESHARK_QT_TS})
get_filename_component(_qresource ${_file} NAME_WE)
set(_qresource_qm "${_qresource}.qm")
set(i18n_qresource "${i18n_qresource}\n <file>${_qresource_qm}</file>")
- set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/i18n.qrc PROPERTIES OBJECT_DEPENDS ${_qresource_qm})
endforeach()
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/i18n.qrc.in ${CMAKE_CURRENT_BINARY_DIR}/i18n.qrc)