aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2016-05-27 22:46:58 -0400
committerMichael Mann <mmann78@netscape.net>2016-06-01 20:35:26 +0000
commit697996a8b0cea260e89bab709a5b556f3ba7b1c6 (patch)
tree9a685c63f3fc9bf8d745aea54e6c57644e0cb60f /ui/qt/CMakeLists.txt
parent374266296d6f8994910e70c7365097b9e5e809a6 (diff)
Create a FieldFilterEdit class and apply it to custom column preference field.
DisplayFilterEdit deals with entire filters and some edit boxes just need a single protocol field. This control will do the trick. Bug: 12321 Change-Id: I8e5837ea9a6955ada29b7e516ea022ab1dd46f0d Reviewed-on: https://code.wireshark.org/review/15595 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 3b56e65dea..841c9d7f2d 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -60,6 +60,7 @@ set(WIRESHARK_QT_HEADERS
export_dissection_dialog.h
export_object_dialog.h
export_pdu_dialog.h
+ field_filter_edit.h
file_set_dialog.h
filter_action.h
filter_dialog.h
@@ -214,6 +215,7 @@ set(WIRESHARK_QT_SRC
export_dissection_dialog.cpp
export_object_dialog.cpp
export_pdu_dialog.cpp
+ field_filter_edit.cpp
file_set_dialog.cpp
filter_action.cpp
filter_dialog.cpp