aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-05-15 17:02:26 -0700
committerAnders Broman <a.broman58@gmail.com>2018-05-16 04:22:20 +0000
commit62999cc6776e2b94e5a888ce77d6452a1020c660 (patch)
tree5fb2f0ac932eb72277e45d59bc298f36c01347c1 /ui/qt/CMakeLists.txt
parentd3427b8a65d926ae4c85d0ec730eaf1a574041c3 (diff)
Windows: Make sure more native dialogs handle HiDPI.
Add a WiresharkFileDialog class, which is a thin wrapper around a few QFileDialog functions that sets per-monitor v2 DPI awareness before showing native dialogs and resets the awareness context afterward. Use it where we call QFileDialog::getXXX. Change-Id: Ib711a70aa94b693a2515804a729f666ea7fbd673 Reviewed-on: https://code.wireshark.org/review/27568 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 5b23e8d7a3..adc875ba72 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -38,6 +38,7 @@ set(WIRESHARK_WIDGET_HEADERS
widgets/stock_icon_tool_button.h
widgets/syntax_line_edit.h
widgets/tabnav_tree_view.h
+ widgets/wireshark_file_dialog.h
)
set(WIRESHARK_MANAGER_HEADERS
@@ -266,6 +267,7 @@ set(WIRESHARK_WIDGET_SRCS
widgets/stock_icon_tool_button.cpp
widgets/syntax_line_edit.cpp
widgets/tabnav_tree_view.cpp
+ widgets/wireshark_file_dialog.cpp
)
set(WIRESHARK_MANAGER_SRCS